Con questa guida sarete in grado di configurare una connessione ADSL su un Router Cisco generico.

I seguenti comandi sono stati testati su un apparato Router Cisco 827 con connessione 4Mbit Tiscali Flat ma "dovrebbe" funzionare anche con altri provider italiani.

Collegarsi al Router tramite cavo seriale o IP di gestione e digitare i seguenti comandi passo-passo sostituendo le login e password dell'ADSL con le vostre.

Dopo aver acceso il router collegate il cavo console al vostro personal computer con emulazione di terminale (Hyper Terminal, Putty o Tutty ad esempio).

Al termine della fase di test il router si fermerà sul prompt: 

Router> 

Per poterlo configurare è necessario entrare nella modalità Enable, digitate sul prompt:

Router>enable 

e premete il tasto INVIO sulla tastiera (dopo aver digitato un comando premere sempre il tasto INVIO). 

A questo punto il router dovrebbe chiedere una password, ma se il router non è mai stato configurato in precedenza 
non verrà richiesta nessuna password. 

Il prompt cambierà da > a #

Router# 

Entrate in configurazione terminale digitando: 

Router#conf t 

Apparirà il seguente prompt: 

Router(config)#

...e digitare i seguenti comandi passo-passo:

service password-encryption

hostname HomeRouter

enable secret 5 passwordGestioneRouter

ip subnet-zero
no ip domain-lookup

interface Ethernet0
ip address 192.168.2.1 255.255.255.0
ip nat inside
no ip route-cache
no ip mroute-cache
no cdp enable

interface ATM0
bandwidth 4096
no ip address
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1

bundle-enable
dsl operating-mode auto

interface Dialer0
bandwidth 4096
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
no cdp enable
ppp chap hostname loginContrattoADSL
ppp chap password 7 passwordContrattoADSL

ppp pap sent-username loginContrattoADSL password 7 passwordContrattoADSL

ip nat inside source list 1 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
ip route 192.168.0.0 255.255.255.0 192.168.0.254
no ip http server

logging trap debugging
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
no cdp run
banner motd ^C Router ADSL Privato ^C

line con 0
password 7 passwordGestioneRouter
login
transport input none
stopbits 1

line vty 0 4
password 7 passwordGestioneRouter
login

scheduler max-task-time 5000
end

 

Salvare la configurazione con il comando:


copy running-config startup-config  

 

Testare la connessione Internet impostando su un PC i seguenti parametri direte:
- indirizzo IP: 192.168.2.2
- subnet mask: 255.255.255.0
- DNS primario: 8.8.8.8
- Default Gateway: 192.168.2.1

 

 

 

 

 

0
0
0
s2sdefault